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I. Introduction

This note aim is to help project managers to produce map quickly using the QGIS software. QGIS (Quantum
Geographical Information System) is a free open source software which functionalities are close to commercial GIS
software (ArcGlIS, Maplnfo...).

Some definitions: A GIS (Geographical Information System) is organized into a series of stratified layers that each
brings a part of the information, which can be:

1. Raster layer: models continuous shape, the layer is sliced by a grid and each cell carries information
(altitude, geology, color...)
2. Vector layer: represents discrete data, precise shape
a. Points (city, catchment...)
b. Lines (road, river, border...)
c. Polygons (country, region, lake...)

Remark: This note was created for QGIS 2.4, Windows 7 and Office 2010. Some differences may appear if software
versions are different.
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Figure 1: Project properties

II1.Load a Map

We wish to start the project by loading a basemap in the project. There are several choices:

o Georeferenced maps (the spatial coordinates of the map are included in the map file)
e Map in image format® + coordinates of at least 3 points of the map (city, houses...)
e Online map (Open Street Map, Google Map ...)

A. Georeferenced map

Add a Raster Layer 'D (Layer > Add Raster Layer), select the georeferenced map file. The layer appears on the
layer panel?, to see it on the main screen: right click on the layer > Zoom to Layer.

Usually the georeferenced map file contains the coordinate reference system (CRS) of the map and QGIS transforms
it in the coordinate system of the project (‘on the fly’ CRS transformation). If the map is badly placed (not on the
right coordinates) the CRS of the map has to be manually entered: right click on the layer in the layer panel >
Properties = General = Coordinate Reference System.

' ‘On the fly’ CRS transformation: the coordinates of each layer are transformed into the Coordinate Reference System of the
project

% Link to two extensive databases for topographic maps : US army map: http://www.lib.utexas.edu/maps/ams/ and soviet army
map : http://maps.vlasenko.net/soviet-military-topographic-map/

* Activate in View>Panels> Layers



http://www.lib.utexas.edu/maps/ams/
http://maps.vlasenko.net/soviet-military-topographic-map/

B. Maps in image format
There is a plugin, included in the standard QGIS install*, which georeferences images: Raster > Georeferencer =
Georeferencer.

7\ Georeferencer - Ba Boukan Kare_georef.tif —|d ﬂ
1. Openaraster™ Ed(Image of a Map : File=> Open Raster) Fls Edt wew Setngs Help

= >
2. Add point (Edit = Add point), on the map click on a
point which coordinates are known (House, city, particular
point)

3. Enter the coordinates of the points chosen

4. Enter at least three points

5. Choose the transformation settings (Settings = o O '
Transformation Settings), Transformation type: linear,

then choose an output raster | 2 -|with a new filename for

Transform: Mot set || 796831, 2085285 || EPs:32615

the futur georeferenced map (ex : Mapname_georef.tif)

(4

7. Close the georeferencer and load the newly created raster in QGIS (the new georeferenced map) as detailed in

6. Start georeferencing (File = Start georeferencing)

section A.
TIP: The georeferencer has a useful tool when working on juxtaposed map. On step 3, instead of entering points
coordinates, points can be chosen directly on QGIS main screen, by choosing points on a juxtapose / backward

From map canvas
map : Click on & P then on the map on QGIS main screen at the chosen point location

C. Online Map

Map available online can be loaded into QGIS, very useful to quickly obtain a basemap, borders, river...
Remark: a « good » internet connection is necessary

1. Install Open Layer Plugin : Plugins=> Manage and Install Plugins = All >Openlayers Plugin=> Install = Close
2. Once the plugin is installed: Web—>OpenLayer Plugin = Select the type of map (ex: Google satellite) or use
OpenlLayers Overview

*If not installed: Plugins > Manage and Install Plugins > All >Georeferencer GDAL > Install = Close
To install a plugin offline = copy the plugin folder into \user\<user name>\.ggis\python\plugin for win7 (\Documents and
Settings\<user name>\.qgis\... for Win XP)



IV.Load points

There are several methods than can be used to load points under QGIS, three are described below:

1. Create points manually
2. Load points from a GPS
3. Load points from an Excel database

The formatting of data points is explained in section D on page 5.

A. Create points manually

1. Create avector layer: Layer 2> New = New Shapefile Layer-> Point = Specify CRS
In new attribute, choose the attribute name (the label of the column of your new database):
a) Type: Text data: city name, houses...
b) Type: Whole or decimal numbers: points data such as number of houses in a village, of latrines, %, ...)
- Add to attributes list
3. OK = Save the layer with the shapefile format (.shp)

4. Add points : Select the layer in the layer panel > Toggle Editing “ (Layer - Toggle Editing) = Add feature
oo

(Edit > Add feature) = Click on the map on the chosen location = Fill the attribute data

F

5. Once all the points are entered, switch off the editing mode “ and save the layer.

6. Modifications can be made by opening the attribute table: right click on the layer in the layer panel-> Open the

Attribute Table. The editing mode must be switched on “  to be able to modify the data.

B. Load the points from a GPS.

1. Create a (.GPX) file with the GPS manufacturer software® (Map Source for the Garmin GPS)
Open the (.GPX) in QGIS : Vector >GPS*>GPS Tools=>Load GPX file>Select the file and the type of data to load
(points, Tracks ...)

3. Modification can be made in the attribute table: right click on the layer in the layer panel=> Open the Attribute

Table. The editing mode must be switched on“  to be able to modify the data.

> To convert various GPS files format to .GPX, the free converter GPSBabel is recommended
® Plugin included in the standard QGIS install. If not installed Plugins = Manage and Install Plugins = All >GPS Tools > Install
- Close



C. Load points from an Excel Database

It is useful to work from an Excel database that contains, as well as the GPS coordinates, the project data. The map

will be easier to update.

1.

In Excel create a sheet with a line containing the data label followed by lines of data (do not merge cells, do not
keep blank line or column inside the data field)

A B c ] E F G
- b |

[u] Localite ¥ Y Lakou Nb Dalles C“ouue.n:ure
1 Latrina
2 L{Chimowo 798447 2086541 51 50 96%
3 2[Feyvobyen TaT51E 2086554 56 37 ST%
4 3| Gapi (Dablet) THRETH 2098372 65 55 1%
B 4|Gaya TAE9E6 2089512 2% 15 48%
[ 5|Gran 2&b TATATS 2097956 50 48 £8%
) &lLabod [Larat) 735400 2098365 37 38 T
g ¥lLarat TI4373 2098672 38 36 T3%
E| &|raaranvil TI5EEE 2098965 48 38 6T
10 alraislat TIGEEE 2097996 40 33 53%
11 10|Mikala 799811.201| 2095517.76 56 27 99%
12 11|0fré 795898 2100242 14 14 T
13 L2|Opisa 797181 2098853 33 20 2T
14 13|Pidém EEES 2098938 50 18 8%

Figure 3: Example of a table with data that can be exported
2. Save the Excel file (to keep an usable version) then Save as =Save as type = CSV (Comma delimited)’> OK
(Save only active sheet) = Yes (keep this format)

3. Open the file with QGIS : Add Delimited Text Layer ,E
with Browse

(Layer = Add Delimited Text Layer) = Select the .CSV

4. If the columns of the table that appear in the bottom of the window are not clearly separated, select the regular
expression delimiter = semicolon for example, if Excel is in French.

5. Define X and Y fields (point coordinates) if not done automatically

6. Check data in the table. If accent marks are not shown, change the encoding (WS2 should work) = OK

7. If points are at the wrong place, the CRS of the layer must be entered manually: right click on the layer in the
layer panel = Properties 2 General 2 Coordinate Reference System (in the example in Figure 3 : WGS 84 /
UTM zone 18N)

To update the layer, the update table in Excel must be saved again on the same file (replace file) with .CSV extension
.
and refresh QGIS o (View = Refresh).

D. Data point format
All formatting modifications are done from the layer properties: right click on the layer in the layer panel 2>
Properties

’ Do not select CSV Macintosh or CSV Dos which have limited encoding support (do not recognize special character)
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a) Style menu:

Single symbol: All the points have the same symbol.

Categorized: Points can be differentiated depending on their attributes. For example, with the data in Figure 3 the
color of the points can follow a color ramp = Select the column « Couverture Latrine »—>choose a color ramp—> 0K

Rule-based: A set of rule can be created that determine the format of the points. Example: we want to color in blue
the points for the villages with a latrine ratio “Couverture” of more than 80% and in red the other villages.

>Add Rule ® - Label: Couverture <80% ->Symbol color: Red

SAdd Rule * > Label: Couverture >80% > —Fields and Values = Double click on «Couverture » 2>
Expression = "Couverture" > .8 20K = Symbol Color: Blue

r" Layer Properties - Localité awvec taux de latrinization | Style

Rule-based -

v |La|:ue| |Rule Min. scale Max. scale |C|:|unt |Duplicate count
@ Couverture <80% {no Filker)

@ Couverture =80% "Couverture" =8

Figure 4: Style determined by a set of rules

b) Labels menu

The easiest: Label this layer with: “Name of the attribute” in our example “Localité”.
Example of presentation that looks OK:
- Text 2> Style: Bold = Size: 8.25 points—> Color: Same as the points color
—>Buffer > Draw text buffer = Size: 1mm - Color: white

->Placement = Distance: 1mm

€]

A little trickier: Click on expression dialog:

In function list =In Fields and Value are listed our points attributes (attributes must be between “double quote”),
text can be added (between ‘single quote’), mathematical expressions ...

Between each expression (attribute, text, math), a string concatenation sign ‘| |" must be inserted.



Exprassion "Attribute localité" Concatenate' enter ()
' Concatenate '(' Concatenate"Attribute lakou" ...

I"Ln::n:lalil:a'l'I [l o S - P g
[ ] "Lakad® ||, "I "MbDalles" ||, "] "Couverture Latrine" || ') ﬂlimnm -f ‘_f
o5t ;_u;p%jf
g
Expresshn "Attribute localité" Concatenate' - 'Concatenate
| Lccalts® || - || CASE WHEN "Couverturs Latrine” .8 THEN Locslté Comverte BNp  COUVErture latrine” > 80% Then 'Localité couverte'

ﬂ'lilh'ﬂ.ﬂ_-'!-l" l.éu::ﬂté_ Euwerté

s

Figure 5: Example of expression that control label content -
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c) Sizing the point area or diameter from data

GﬁMcgt
3 B OPTE = SSEaslion
Figure 6: Example of point area according to the number of family (lakou) in red and latrine in blue

1. Set the red points color: right click on the layer containing the data points in the layer panel = Properties 2>

Style > Single symbol = Marker = Simple Marker—->Color Red.

2. Set the red points diameter: In the same style menu: Click on Marker = Advanced = Size Scale Field 2>

expression = here “Lakou” / 5 2 OK. Then again Advanced = Size Scale Field = Scale Area

3. Set labels placement to avoid overlapping the points :Properties = Labels = Label this layer with : “Localite” >

Placement > Around point%Distance%g - Edit 2 sqrt( "Lakou" /(5*Spi))+1 ®

4. Add the blue points: right click on the layer containing the red points in the layer panel > Duplicate. Then right
click on the new layer and in Properties set the color to blue, in advanced set the area to “latrines” / 5, remove

the label.

® The radius of the points: R = \/% = ’%’”5 plus 1 pixel of extra space



5. Inthe layer panel, drag and drop the blue points layer above the red one in order for it to be on the foreground.
E. Lines / Polygons to display border

Lines and polygons are used to draw borders, rivers...

a) Draw borders
1. Start by loading a map where borders are clearly visible (an online map can work —see section B. on page 3)

2. Create a vector layer : Layer> New = New shapefile layer-> Polygon = Add at least one attribute for the name
of the area > OK - Save the layer as (.shp)

3. Add points: Select the layer in the layer panel = Toggle Editing Mode “ (Layer—> Toggle Editing) 2 Add a
s
polygon (Edit > Add a Feature) Click on the administrative map following the borders = Once the
polygon is done right click on the map = Fill the attribute

Once the polygon done, points can be moved in Editing Mode by clicking on /% (Edit 2 Node Tool)

5. When drawing a new area that has a common border with the first polygon: Settings = Snapping Option 2 Thick
the layer that contain the border then tolerance = 1 (adjust if necessary) 2 Add a New Feature - click onto the
common border points (automatic snapping) = once the common border is done, untick the snapping option
and draw the rest of the polygon.

6. Once the areas are drawn, untick the Toggle Editing “ and save the layer.

b) Polygon formatting
Right click on the layer 'border’ in the layer panel = Properties = Style =>Single symbol = Simple fill 2Symbol
layer type : Outline : Simple line.

Line settings can then be adjusted and area label added

c) Lines
The same process can be used to create lines (river, road...).



F. Color graduation fill in polygons
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Figure 7: Example of a map that shows the density of the population, each polygon (here village) is filled with a color
according to its density.

1. Create polygons, as described in IV.E.a) Draw borders on page 8.
2. Open the attribute table: right click on the layer in the layer panel=> Open the Attribute Table.

3. Do a CTRL + A (select all) followed by a CTRL + C (copy) and paste in a excel spreadsheet. The first column
header should be “wkt_geom” and the column should contain all the Well-Known Text (WKT)
representation, the other column should contain all the information you wish to display (do not merge cells,
do not keep blank line or column inside the data field). Save the excel file as .csv.

4. Open the file with QGIS : Add Delimited Text Layer ,“ (Layer > Add Delimited Text Layer) = Select the
.csv with Browse. QGIS should automatically detect the WKT geometry.

The polygon formatting can be set in the layer properties. To display a map such as the one in Figure 7, select >
Properties = Style > Graduated = choose the column containing the data (here field_10 containing the population
density) 2 number of classes (here 7). >Choose a color ramp —>click on classify = the graduation can be
customized by a double click on Value and Label



V. Publishing

/1 Layer Properties - Localité surface 2015 | Style x|

o Graduated -
o Column | field_1o T

Symbal M change.. Classes |7 =

Color ramp T source] - Trvert Mode | Quantile (Equal Count) | =
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W Layer rendering
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Figure 8: Setting the graduated style to display the Figure 7 map

Legend

W Main properties

Title Latrinisation#Baoukan Kare
A Compose the map Title alignment: Left -
QGIS manages the publishing and printing of map from the Map A v
b ‘W'rap bext on Ed

Print Composer: New  “(Project> New Print Composer)

:'\.

and the manager Jﬁ' (Project = Composer Manager)

1.

Open a new print composer : Map Name = OK
Define the paper format : Panel on the right 2 Composition = Paper and quality

Add a new map l—_EE (Layout = Add Map) = Trace a rectangle on the sheet (in the print composer, item are
g

selected using the button — ' Select / Move item)

Setup map extent and the scale: Click on ! % (Layout > Move Content), keeping the left button pushed the
map can be moved, the scale can be changed with the mouse wheel. To setup the scale more precisely, enter
the scale value (Item Property = Scale)

- o5
Ll

Add a legend : -0 (Layout = Add new legend) > Choose a title’>Add

[

legend > Select the layer in the legend item list>Edit layer title '—

)
or remove | layer from the

- In legend item untick “Auto Update”

Then we can:
Figure 9: Carriage return in the legend title

a) Addascalebar *

° Carriage return: put an unused character in the title: # then in “wrap text on”: # cf Figure 10.



=
b) Add a north facing arrow — ** = Item properties = Path : a picture of an arrow : image collection in the
QGIS installation folder (for example C:/Program Files/QGIS Chugiak/apps/qgis/svg/ ) text can then be
added (ex : N north of the arrow) bt
c) A referenced grid = Select the map = Item properties 2Show grid = Choose an Interval (Interval in
degrees, to obtain an interval in minute 1/60 = 0,01666666)

B. Publish the map

The composed map can:

1. Be printed directly on the composer

) =
2. Beexported as PDF ° & (Composer >Export as PDF), these files are quite large® (Often above 10 MO).

a) The cleanest solution is to open these file with the commercial software Adobe Acrobat Professional**-> File
- Save as 2 Optimized PDF > Color Image : 100 ppi for image above 125 gives good results (Good image
compression algorithm, no loss of text quality)

b) The other solution, with a poorer quality is to change the resolution (before the PDF export) in the print
composer = Composition = Export resolution = 150 dpi = Print as raster™

3. Be exported to an image format =) (Composer 2 Export as image): The JPEG format has a better compression
ratio, the size of the image created is managed by the export resolution (composition = Export resolution =
150 dpi). 150 dpi seems to be the lower resolution which gives an acceptable result for topographic map.

10 A free PDF compression solution, which as a lower quality : Install Ghostscript then GSView then open the PDF in Gview >
Convert = pdfwrite = Resolution : 200 2 OK (manage the text as a picture that becomes quite unreadable below 200 ppi)

! Not to be mistaken with the free Adobe Acrobat Reader
2 All the layers are merged and the final result is saved as a raster (as only one image)
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